166 cd player problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 11-12-07 Thread Starter
Status: -
Join Date: Dec 2007
Posts: 2

Member car:

alpha 166

166 cd player problem

just got this car and love it. but... when I loaded the cd player and put the cassette in there was no way the unit would play the music. finally opened the boot to see if it appeared to be getting power and found that it would eject the cd cassette as soon as it was put in. is some entity trapped inside or is there a more logical explanation?
mallowpuff is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: 166 cd player problem

Moved to 166 Lounge
BigFoot is offline  
Status: -
AO Silver Member
HowardA's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: Derbyshire
Posts: 1,549
Images: 5

Member car:

2010 S350Bluetec

Re: 166 cd player problem

definitely possessed.
HowardA is offline  
Status: -
AO Member
Join Date: Jun 2003
Location: Surrey
Posts: 299

Member car:

166 V6 3.0

Re: 166 cd player problem

You don't seem to have attracted a reply yet. I have the opposite problem with my CD - I can't get the cartridge out of my CD player. I've taken it apart and it's fiendishly complicated.

I tried all the local car audio people without success, they don't have the necessary head unit to test it.

Contacting Becker was not entirely helpful either. They have two service agents, in Tipton and Hartlepool (I live in Surrey). They are:

Advance Electronics and Logistics 0121 522 6652

Putnoe Radio Services Ltd 01429 869220

I'm going 'up north' before Christmas and I'll try Putnoe then.

mikealdren is offline  
Status: -
AO Member
Join Date: Nov 2007
County: -
Posts: 41
Re: 166 cd player problem

My local repair man has no problems with them - he has fixed three for me but he does say they are generally unreliable!
Meldrew is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

166 , player , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome