2L TS coil pack testing...how? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-12-07 Thread Starter
Status: -
AO Member
Join Date: Aug 2007
Posts: 63
2L TS coil pack testing...how?

2L TS running rough, suspect plugs or coil packs. Is there any way of testing them e.g. -measure resistance, where, how...any help?
bk.bas is offline  
Sponsored Links
Status: -
AO Member
dex's Avatar
Join Date: May 2004
Posts: 90
Re: 2L TS coil pack testing...how?

Having two sets of coil packs/leads/plugs gives you some redundancy against this sort of problem - unless of course there are several faulty components.

Unplug one of the coil packs see how it runs, then swap and plug just the other one in and run it again. Assuming there isn't a fault with both packs it should run the same both times, unless there are issues with the several plugs and/or leads. Any difference in running, then swap the leads to the other coil pack and try again - problem follows the leads then faulty leads or plugs - problem clears then faulty coil pack so swap the other input lead into coil pack and repeat the last step.
dex is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

coil , pack , testinghow

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome