idle problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 22-09-07 Thread Starter
Status: -
Join Date: Sep 2007
Posts: 4

Member car:


idle problems

been offered a cheap 166 has a few niggley probs but the main one is that the engine dies and revs high occassionally, apparently it has recently had a engine rebuild, im not too hot on alfas so not sure if its worth the hassle, what do you guys think the problem could be, idle valve, dirty sensor, auto choke. something moe serious its a 1999 2.0 16v t-spark model.
any advise would be great
yorks85 is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Mar 2005
Location: Leeds England
Posts: 2,220

Member car:

GTV V6, ex 166er

Re: idle problems

How cheap?
CrispDust is offline  
Status: -
AO Member
Mad_mike's Avatar
Join Date: Sep 2007
Location: Ireland
County: Westmeath
Posts: 433
Images: 12
Re: idle problems

Check the flexible pipe on the right hand side on top of the engine before the air breather. Its a flexy pipe with folds and it seems to be a common problem that the folds on the pipe split when the rubber perishes. I just bought a 99 2.0 TS and had similiar problems and the pipe was gone. A quick repair with superglue sorted it for the meantime
Mad_mike is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

idle , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome