Paranoid - electrics and starting issues! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 31-08-07 Thread Starter
Status: Is three Alfas too many!?
AO Silver Member
Unkle Munkle's Avatar
Join Date: Mar 2003
Location: United Kingdom
County: -
Posts: 1,472
Hmmm Paranoid - electrics and starting issues!

Hi all,

Last weekend my 3.0 Super was messing about. I went to start the car and all the lights on the dash came on in 'position II' on the ignition as normal. I then tried to start the car and there was nothing - no sign of life. When I tried again, everything had failed.

I thought the battery was knackered, but that has turned out to be fine as it turned over perfectly. The only way I got it going was to make contact with another battery (ie jump start). I re-set the alarm/locking and it started. I guess there was interferance with the immobiliser.

Upon losing my beloved 164 QV to fire, I decided to disconnect the battery and I noticed the positive terminal was very tight. I also noticed that it had cracked and broken in several places and therefore not making good enough contact on the battery terminal to start the car. This may of engaged some sort of immobiliser issue.

I'm hoping that, now I've got a new one, that this will rectifiy the problem. I can't help feeling there's an electrical gremlin that may be causing the problem as it was so sudden.

Anyone else experience anything similar?
Unkle Munkle is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

electrics , issues , paranoid , starting

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome