no power to 166 ICS unit - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 14-08-07 Thread Starter
Status: -
AO Member
justalfaspares's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Merseyside
Posts: 27

Member car:


no power to 166 ICS unit

I have just fitted a new engine to a 2001 2.5v6 166 and everything works as it should apart from the ICS unit! I have the code but there appears to be no power to the unit (eg all climate buttons work but the display does not function and no audio)
I thought i would have more problems with the mechanical side but this is really confusing me!!
Does anyone have any information that may help me?
justalfaspares is offline  
Sponsored Links
Status: -
AO Member
Join Date: Apr 2007
Location: Hertfordshire / Essex
Posts: 232
Re: no power to 166 ICS unit

have you tryed the fuse on the back of the unit? any other ics related fuses? connection on the back?
Marco166 is offline  
Status: -
Join Date: Aug 2007
Posts: 3

Member car:

alfa romeo 166

Re: no power to 166 ICS unit


Please help to get the ICS code for my car Alfa 166.
Becker type BE 2580 SN Y5028757. My code contains 4 digits (****)
Thanks for all!

CINEK is offline  
Status: AROC 916 Registrar
AO Gold Member
Mitch916's Avatar
Join Date: Nov 2002
Location: United Kingdom
County: Kent
Posts: 8,803
Images: 8
Re: no power to 166 ICS unit

From memory (I dont have my handbook at work!) I think fuse 18 is for the ICS.
Mitch916 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

166 , ics , power , unit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome