166 pulling to one side - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 04-07-07 Thread Starter
Status: -
AO Member
Join Date: May 2007
Posts: 43

Member car:

166 super lusso

Wave 166 pulling to one side

My 166 super pulls to the right under acceleration and back to the left on deceleration.
It is really bad when in 1st and 2nd gear and it has only just passed an MOT so there is not anything obviously wrong with the suspension.
Has anyone else had this problem?
colin166 is offline  
Sponsored Links
Status: ex Alfa owner
AO Member
stephendjb's Avatar
Join Date: Sep 2006
Location: Manchester
Posts: 643

Member car:

166 2.5 V6

Re: 166 pulling to one side

Probably a bush in one of the tracking control arms
stephendjb is offline  
Status: Thinking Giulietta QV...
AO Silver Member
Unkle Munkle's Avatar
Join Date: Mar 2003
Location: United Kingdom
County: -
Posts: 1,476
Re: 166 pulling to one side

My 164 did this and it needed new wishbones. Worth checking as it is an awful sensation....
Unkle Munkle is offline  
Status: -
AO Member
Mad_mike's Avatar
Join Date: Sep 2007
Location: Ireland
County: Westmeath
Posts: 433
Images: 12
Re: 166 pulling to one side

Mine is doing this but the other way round. I put new tyres on last week and since that I have been scared ****less 3 or 4 times!! Under heavy braking, the car pulls violently to the left. Any ideas on what this would be? Seems very odd that it showed up only after putting on new tyres or is it just coincidence???
Mad_mike is offline  
Status: -
AO Silver Member
Trailbraker's Avatar
Join Date: Mar 2005
Location: Ireland
County: -
Posts: 5,179

Member car:

156 GTA

Re: 166 pulling to one side

Check the tyre pressures are the same, and the tyre surfaces for damage.

Failing that, its probably suspension related.
e.g. completely badly worn bushes/damaged wishbone or similar.
Trailbraker is offline  
Status: -
Join Date: Nov 2007
Posts: 3

Member car:

Alfa 166

Re: 166 pulling to one side

I had this problem on my old 164 and I my 166 was going the same way. The 'track rod end joint' and 'steering rack end' have just been replaced and greased; now all is straight and level.
Greyflier is offline  
Status: -
AO Member
Join Date: Feb 2007
Location: United Kingdom
County: Berkshire
Posts: 844
Re: 166 pulling to one side

I had this problem on my 166 TS. I checked the tyre pressures and they were way out. After they were all eaqualized the car tracked straight.
GFK is offline  
Status: -
AO Member
Join Date: Jun 2003
Location: Surrey
Posts: 299

Member car:

166 V6 3.0

Re: 166 pulling to one side

Did you ever solve this?
mikealdren is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

166 , pulling , side

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome