164 Super Alarm Problems (Weird) !! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 18-06-07 Thread Starter
Status: -
AO Member
Join Date: Nov 2006
Location: Malta
County: -
Posts: 231
Help 164 Super Alarm Problems (Weird) !!

Good Afternoon,

I've finally realized that My newly purchased 164 Super 24V has an alarm fitted. The thing is that when I press the keyfob (batteries changed) if the doors are locked they unlock and the alarm is activated. If I press it again, the doors don't lock again, the lights don't flash but the LED stops flashing and the car alarm is deactivated.

It seams like the lights only flash to arm the car although it unlocks the car rather then locking it !! What could the problem be ?

On another note I have the driver's side mirror not folding, no noise, no motor sound nothing, the mirror is adjustable and does demist but doesn't fold. The other mirror works fine, any ideas ? Do I have to remove the entire trim to get to the mirror or just the top part where the air is released ?

Your help is much appreciated,


keithhm is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jan 2007
Location: Berkshire
Posts: 145
Re: 164 Super Alarm Problems (Weird) !!


Why bother with the alarm?
When I bought my 164 seven years ago, the woman that I bought it from told me that it was tricky to operate. The key fob has to pointed towards to interior rear veiw mirror (where the sensor is located)
As it is an early system, it didn't have sensors everywhere, that can be operated from all angles, unlike modern cars.

The alarm can be switch off from inside the boot. There is a flap of carpet on the R/H side with an isolator switch underneath.

Who is going to pinch a 164 anyway? Doesn't really appeal to 'Jack The Lads' or have a decent resale value! (It's just the baby you love)

Concerning the (none)retracting mirror. This is a common problem. There have been posts on the subject but nothing really helpful.
I have the same problem, L/H ok, R/H not working. In my case, I can hear the motor working but it seems to be disconnected (stripped?) from the mirror body.

To completely remove the mirror would mean gaining access to the electrical connectors within the door panel. Physically dismantling the mirror is where things become vague! Have you tried the American site alfa bulletins?

alfakid is offline  
Status: Alfa-less :(
AO Gold Member
niallmoran's Avatar
Join Date: Oct 2003
Location: Dundee
Posts: 6,287

Member car:

'02 156 1.8 TS

Re: 164 Super Alarm Problems (Weird) !!

there's a stolen recovered 164 on ebay at the mo so they must appeal to some of the rascals I think old cars in general appeal as the are easy to get into and easy to start with pretty low tech alarms/immobilisers...
niallmoran is offline  
(Post Link) post #4 of 4 Old 25-06-07 Thread Starter
Status: -
AO Member
Join Date: Nov 2006
Location: Malta
County: -
Posts: 231
Hmmm Re: 164 Super Alarm Problems (Weird) !!

Good Morning,

Thanks for the tips, I'm not worried that someone might steal the car but steal things in it ! (Stereo, Papers, CD's, etc...)

I'm trying to wire it up to a new System with remote engine start but at the same time keep the immobilizer working. I've been looking at the pinouts for the Alarm System and Can use the Inputs from the various sensors wired up from the factory.

Does anyone know if the electrical windows are positive triggered or negative ? Also I looked at the Window controls and the wires are tiny, can't figure out which wire is for folding the mirrors. Anyone knows their colours or voltage ? My guess would be a negative trigger due to thin wires but which goes where I have no Idea !!

Anyway thanks for your Help !


keithhm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

164 , alarm , problems , super , weird

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome