Misfiring V6, but ok after switched off/on - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 14-06-07 Thread Starter
Status: -
Join Date: Mar 2007
Posts: 8
Images: 2

Member car:

Alfa Romeo 166

Misfiring V6, but ok after switched off/on

This morning my 166 3.0 started with a misfire, that it could not seem to shake off. It did not really want to rev much higher than 2500 rpm. When I completed my 10 minute or so run to work, it was still acting every bit as bad. I tried starting it up again after sitting for a couple of minutes - and every thing is back to normal ????
.. is it possible the ECU tried to cope with a misfire from cold-start, going into some sort of 'coping' mode, and would not return to normal until it effectively got a reboot by switching off and on completely ?
(The reason I am started thinking along these lines, is that a couple of times the radio and air-con have stopped, and would not restart until the ignition had been turned off, then on. .. and that was around 2 months ago - no such trouble with either device since.)
Murray is offline  
Sponsored Links
Status: Alfa-less :(
AO Gold Member
niallmoran's Avatar
Join Date: Oct 2003
Location: Dundee
Posts: 6,287

Member car:

'02 156 1.8 TS

Re: Misfiring V6, but ok after switched off/on

i'd just put it down to good old italian temperament
niallmoran is offline  
Status: -
AO Member
Join Date: Apr 2007
Location: Hertfordshire / Essex
Posts: 232
Re: Misfiring V6, but ok after switched off/on

she just wanted to show you whos the boss
Marco166 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

misfiring , off or on , switched

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome