still idle - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-05-07 Thread Starter
Status: -
AO Member
Join Date: Feb 2007
Location: ireland
Posts: 51

Member car:


still idle

on going idle issues, tried an ecu reset and then throttle reset but to no avail.
when i held idle at 2000 revs and took my foot of the throttle the revs did not drop, i then tweaked the throttle cable by the throttle body and they dropped.
but its not consistant, any ideas before i go to alfa.

i have cleaned the throttle body and afm and on both occassions there was some brief improvement but it always came back.

johnhanrahanmgt is offline  
Sponsored Links
Status: Alfa-less :(
AO Gold Member
niallmoran's Avatar
Join Date: Oct 2003
Location: Dundee
Posts: 6,287

Member car:

'02 156 1.8 TS

Re: still idle

sounds like the idle actuator...
niallmoran is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome