Climate control Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 04-05-07 Thread Starter
Status: -
Join Date: Jan 2007
Posts: 7

Member car:


Help Climate control Problem

Hi all,

I have owned a 1999 166 2.5 V6 for 3 yrs now and today while driving with the air con on - it stopped working. The message on the screen displayed "Air Conditioner fault - contact workshop". The display unit works fine but even when I put up the temperature to a higher setting, I get nothing from the blower fan? I seem to hear all the solenoids clicking but no air whatsover is blowing. I checked the fuses, all seem OK. Seems like the air con unit in these cars are very unreliable but having said that I have never had the air con unit serviced. Has anyone any ideas before I bring it to my alfa garage and probably face a huge bill.

faers1 is offline  
Sponsored Links
Status: Alfa-less :(
AO Gold Member
niallmoran's Avatar
Join Date: Oct 2003
Location: Dundee
Posts: 6,287

Member car:

'02 156 1.8 TS

Re: Climate control Problem

sounds like it could be the fan motor....
niallmoran is offline  
Status: "My other car'sa 166 TWO twice"
AO Gold Member
Pomeo's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: South Lanarkshire
Posts: 10,642
Images: 27
Re: Climate control Problem

welcome faers1

wotta first post.

Did you have no other symptoms.Ie acting up before.

the common fail is a smell of burning when fan fails.
Crossa did a good post on replacing fan
Pomeo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

climate , control , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome