166 2.0 Ts - Rip - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 05-03-07 Thread Starter
Status: -
AO Member
mentos's Avatar
Join Date: Aug 2006
Location: Mayo, Ireland
Posts: 30
Wave 166 2.0 Ts - Rip

I'm afraid that my 166 has died a rather violent death.

About three weeks ago I was on the motorway when the main bearings on the crank decided they had enough. This in turn snapped a con rod which left a rather sizeable hole in the engine block.

I got it towed to an alfa "specialist" who advised me on the damage; Second hand "reconditioned" engine + Clutch 2500...not too bad I suppose. I also got him to do a top to toe, just to see what else was waiting for me in the future.....he came back with nothing much bar the suspension....1100 to tidy it up.....3000 to put it right!

Mmmm....spend 5500 on a car worth no more that 6500 at best....don't think so! So we came to an arrangement, he took my 166as it was I gave him another 2500 and I walked away with a mint 156 2.0 Selespeed, with brand new piston rings, gaskets, timing kit, brakes, tyres, oil pump & clutch......happy days!

I did love my 166, however I have to admit, although the 156 is smaller, it is a far superior car. One thing I certainly will not miss about the 166 is the ****ty suspension, which you can do very little about without spending serious cash.

Well goodbye then, I'm off to the 156 section.

mentos is offline  
Sponsored Links
Status: -
AO Silver Member
HowardA's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: Derbyshire
Posts: 1,549
Images: 5

Member car:

2010 S350Bluetec

Re: 166 2.0 Ts - Rip


Can't agree about the 156 - the 166 is in a different league for quality & feel, and comfort IMHO of course
HowardA is offline  
Status: AROC 916 Registrar
AO Gold Member
Mitch916's Avatar
Join Date: Nov 2002
Location: United Kingdom
County: Kent
Posts: 8,803
Images: 8
Re: 166 2.0 Ts - Rip

[QUOTE=mentos;948934]however I have to admit, although the 156 is smaller, it is a far superior car.


I like the 156 and would consider one no problem.

But that statement? Crap.
Mitch916 is offline  
Status: Alfa-less :(
AO Gold Member
niallmoran's Avatar
Join Date: Oct 2003
Location: Dundee
Posts: 6,287

Member car:

'02 156 1.8 TS

Re: 166 2.0 Ts - Rip

i don't see it either TBH....not saying the 166 is without it's faults but that's why we love 'em
niallmoran is offline  
Status: Lusting after a Peroni
AO Member
Join Date: May 2006
Location: Switzerland
County: Vaud
Posts: 433
Images: 15
Re: 166 2.0 Ts - Rip

I have had a 156 2.0TS and currently have a '04 new shape 166 2.0TS and ta 156 2.4JTD 20V MJET - completely different animals - the 166 is a more sedate drive and is an executive motor - the 156 is a mad thing that makes you want to thrash it.

The 166 suspension (I think they revamped it for the 2003 relaunch) is brilliant compared to the 156.

I just wish Alfa hads shoved the 20V Mjet in UK bound 166s.
166lover is offline  
Status: - Update
Posts: n/a
Re: 166 2.0 Ts - Rip

sorry to hear the news about your 166, although good news that you now have a 156...

i have to agree with the previous posts...they are two completely different beasts and therefore impossible to compare...both are great in their own ways...
Status: -
AO Platinum Member
Gary Slegg's Avatar
Join Date: Feb 2006
Location: North Wales
Posts: 16,710
Re: 166 2.0 Ts - Rip

I agree with Mike, sorry to hear about your problems though
Gary Slegg is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

166 , rip

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome