164 headlamp fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 11-02-07 Thread Starter
Status: Mr MoT Man
AO Member
johnkyrle's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Gloucestershire
Posts: 401
Help 164 headlamp fault

HELP.My 164 V6 1991 has developed a strange fault.The offside headlamp will only work on dim dip.The sidelight works fine there is no dip or main beam.We have checked all the obvious,i,e new bulb connectors,and have even discovered there was a break in the earth feed so replaced that wire.When fed direct with a power probe the light works fine.Swopping relays has made no difference either My friend has suggested that it could be the dim dip relay but where the hell is that?Any ideas,PLEASE.
johnkyrle is offline  
Sponsored Links
Status: -
AO Member
Join Date: Mar 2002
Location: WSM UK
Posts: 518
Images: 6
Re: 164 headlamp fault

the 24v has fuses for left high beam and one for right and also a relay for high beam, probably different layout on 12v. On mine high beam relay bottom of the three relays on left in fusebox and fuses numbered F5 and F6. Get a cardisk and it will save you lots of hassle.

Mike M is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

164 , fault , headlamp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome