My bella had a chill - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-01-07 Thread Starter
Status: -
AO Silver Member
Join Date: Mar 2005
Location: Leeds England
Posts: 2,220

Member car:

GTV V6, ex 166er

My bella had a chill

Did run down to London 2 weeks ago (400 mile round trip) in the freezing fog we had. Temp gauge struggled to get above 70 most of the way there and back- assumed a broken thermostat stuck open. MPG shot up presumably due to rich mixture (was with wife so NO Italian driving,,,,,) Also taking forever to get up to temp.
Dropped in at Alternative Auots today and sure enough Steve had the correct thermostat at £17.50. He said he will do a list for 166 as he's getting quite a few enquiries on various things.

Took old thermos off and low and behold stuck open. Still can't work out those weird Alfa jubilee clips (not the nice Air pipe stainless steel ones) so just replaced with a bog standard 45mm clip.
Bella is now toasty warm!!
CrispDust is offline  
Sponsored Links
Status: Alfa-less :(
AO Gold Member
niallmoran's Avatar
Join Date: Oct 2003
Location: Dundee
Posts: 6,287

Member car:

'02 156 1.8 TS

Re: My bella had a chill

that would be great if steve does a list for the 166 as his 156 list is great!
niallmoran is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

bella , chill

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome