Squealing 166 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 03-06-06 Thread Starter
Status: Cento per cento del cuore di sport !!!
AO Silver Member
alfa scozia's Avatar
Join Date: Apr 2005
Location: United Kingdom
County: Stirling
Posts: 3,092
Hmmm Squealing 166

Long time no post.......

The 166 2.5 is running well right now, I'm averaging 800mls a week to and from work, driving from Scotland to Tamworth on a Monday and the return leg on a Thursday night.

I have found a great mobile mechanic in Tamworth who is willing to take on every job I throw at him and he's cheap, he even does the cambelt change for £120 + The Parts.

Ok so recently I have had the groan of a wheel bearing going, so I went ahead and had the front two changed OUCH they ain't to cheap, that has not resolved the issue however and it would seem that it could be the rear offside ........... this has been compounded by a horrendous squeal from the same corner, but it did it for 320 miles on Friday so it's quite alarming, brakes are spot on, discs look clean and were new 4 months ago so I'm at a bit of a loss, has anyone had similar brake/hub/bearing issues ???

All toll the car is munching the miles in her stride, she should though, the engine has only covered 58k mls, the rest of th car having done 113k mls (i'm expecting other issues due to this combo).

Oh and issue number 2 which is a tad alarming too, when i sit in 5th on the mway for a couple of hundred miles it's stuck there when i go for forth, once it releases it takes a while to loosen off, I've had the box oil replaced with the right semi synth but to no avail, again calling on anyone who has has a similar issue, not sure if it's heat related or if it's a cable issue or even a box mounting, any suggestions welcome. The box is fine on local runs it's only on extended m/way runs, thats why I'm thinking heat build up

Thanks in advance for any help.

alfa scozia is offline  
Sponsored Links
Status: Summer's here - roof is down!
AO Member
Cluffstarr's Avatar
Join Date: Jan 2006
Location: United Kingdom
County: Somerset
Posts: 931
Hmmm Re: Squealing 166

I too have had a squealing sound. I have been told that squeaky brakes on 166s are common as the brake pads needing heat in them, but surely this cant be the case as it's intermitent? Tanking it down the motorway with no-one following - slamming on the anchors does help, it's just so frustrating. Around town it's OK - not going far, but on a 300 mile trip, when the radio's run out of good songs and you just want some quiet it can be very very annoying!

Any advice / help would be appreciated. Had the car serviced less than 3k miles ago and new pads were put on. Whenever I push the "Check" button to test the system lights, the front brake wear light stays on for about 10 seconds more than the others. Front pads should do atleast 25k for normal driving in my experience. I'm concerned that the pads may have been put on incorrectly (if it is indeed the brakes), but the brakes stop the car very well still...

History - 1999 156 2.0 TS - 1999 GTV 2.0 TS - 2000 GTV 2.0 TS, 2000 166 2.5 V6 24V - 2002 147 2.0 TS - 2004 147 2.0 TS
Current - 2001 Spider 2.0 TS, 2006 Jaguar XK8, 2006 VW Golf GTi
Cluffstarr is offline  
(Post Link) post #3 of 3 Old 17-06-06 Thread Starter
Status: Cento per cento del cuore di sport !!!
AO Silver Member
alfa scozia's Avatar
Join Date: Apr 2005
Location: United Kingdom
County: Stirling
Posts: 3,092
Re: Squealing 166

The gear shift situation is not bothering me to much but seems to be worsening slowly, no issues up and down the box on short journeys but a pain to haul out of 5th on long trips, any ideas ????
alfa scozia is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

166 , squealing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome