Uneven Running 166 Sport-tronic - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-04-06 Thread Starter
Status: -
AO Member
Join Date: Apr 2006
Location: Melbourne Australia
Posts: 55
Uneven Running 166 Sport-tronic

Hi there from Australia

I am trying to track down a problem with my 166 3.0 Sport-tronic , it has what seems to be un-even running at about 60kph or approx 1500-1800rpm in 4th gear. It feels like the engine is mis-firing but I am not convinced of it. I have had the MAF replaced in the past at it did seem to improve it but still didn't fix it , plugs have been done and when hooked up to the Alfa diagnositics it doesn't show any sensor problem I have been told by Alfa dealer they have had some cases of a locking bolt which locates a plate that one of the driveshafts goes through which they have had a couple where the bolt has come loose. Anybody got any thoughts. It actually feels like a out of balance wheel but have had several different sets of rims on it along with all rims being confirmed as being perfectly balanced by several tyre shops.
Hwalker166 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2005
Posts: 18
Images: 8
Re: Uneven Running 166 Sport-tronic

i think its the air flow senor, i had the same problem. It does not come up as a fault code, i would try it first before you spend any big money.
If it is the air flow sensor(air flow meter) it will make a hell of a difference.

166 3.0 sport tronic 1999
d-j1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

166 , running , sporttronic , uneven

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome