166 2.5 V6 cold start - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-04-06 Thread Starter
Status: -
AO Member
Join Date: Mar 2005
Posts: 12

Member car:

166 2.5 V6

Warning 166 2.5 V6 cold start

My 1999 166 2.5 V6 dosen't fire up early in the morning if it has been frosty. Engine turns but dosen't fire. A few hrs later when the weather warms up, the car starts first go. On the dash that imobiliser light stays on when I have the issue. The light goes off when the air temperature outside is warmer and the car starts. Anyone out there ever experienced this type of issue in frosty weather???????????????
eddie1 is offline  
Sponsored Links
Status: -
Alfista for ever!
superguinness's Avatar
Join Date: Apr 2005
Location: Sheffield
Posts: 282
Images: 5
Re: 166 2.5 V6 cold start

Car battery needs replacing maybe?
superguinness is offline  
Status: -
AO Silver Member
Cheradnine's Avatar
Join Date: Mar 2004
Location: Bristol
Posts: 1,466

Member car:

164 Super 24v

Re: 166 2.5 V6 cold start

Does it spin with out trying to fire at all, or does it cough & splutter without catching?

If the latter, it may be a temp sensor not giving a correct fuel/air mix.
If the former, I'd guess the immobiliser - never had one so only guessing
Cheradnine is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

166 , cold , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome