166 Suspension Question - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 26-03-06 Thread Starter
Status: Delayed at the airport!
AO Silver Member
Graham_Brera's Avatar
Join Date: Jun 2005
Location: United Kingdom
County: Glasgow
Posts: 1,113
Images: 5
Cry Like A Baby 166 Suspension Question

Ive just got a full set of tyres fitted on my car last week and since then ive been getting a vibration from the front, ive had all the wheels rebalanced but its still there. It does start to get bad between after 55mph. When the guy let the jack down it did come down with a hell of a thud and im just wondering if it might have broken something. Any ideas??
Graham_Brera is offline  
Sponsored Links
Status: -
AO Silver Member
Tony Rome's Avatar
Join Date: Jan 2006
Location: Germany
County: Berlin
Posts: 1,815
Images: 21
Re: 166 Suspension Question

When the wheels were re-balanced, did you check to see whether they were buckled? Apparently, they are pretty easily damaged, often on the inner part of the wheel. I found that two of mine were badly buckled and I have temporarily put them on the rear, to minimise the vibration problems. It's still noticeable, though, especially at higher speeds.
Tony Rome is offline  
Status: -
AO Member
Join Date: Dec 2005
Location: near Bridgwater,Somerset
Posts: 159

Member car:


Re: 166 Suspension Question

Possible bent suspension arm? did he jack it up on one of the arms?
might be worth checking out
gamphy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

166 , question , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome