immobiliser fault on a 164 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 03-03-09 Thread Starter
Status: -
AO Member
OLD ALF's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: -
Posts: 393
immobiliser fault on a 164

my 96 3litre 164 has been at a main dealer for 3 weeks with an unsolved immobiliser problem .[had to use dealer because of key code issue.]
symptoms .are key code .engine management and alarm light showing on dash.
no power going to fuel pump connector but punp works if fed directly
engine turns over .spark ok ,fuel cut out ok.injector pulse ok.
has anyone any experience which could help a new dealer who is fumbling in the dark at my expense.and having to resort to obtaining old wiring diagrams from alfa gb
no immobiliser fault code listed for m1.7 system .
all keys available.
already lost a 89 3l to electrical gremlins in past year/
and low mileage t/s stolen
fed up

young alf
OLD ALF is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

164 , fault , immobiliser

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome