Heater - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 19-01-09 Thread Starter
Status: -
AO Member
Join Date: Nov 2008
Location: Sweden
County: -
Posts: 233

The heater on my 166 seems to work ok and puts out heat when the motor is warm. (when i punch-in a temp of 22,23 or 24). But it does not blast out the heat like some other cars do and it seems to takes a long time to go from 0 up to 22. What performance should i expect from my heater? Should i have the Alfa shop check-it-out to see if it is working as it should? I changed the pollen filter a few months ago thinking that would help but no better than before.
Vazboy is offline  
Sponsored Links
Status: -
AO Member
dafi166's Avatar
Join Date: Mar 2008
Location: Beirut , Lebanon
Posts: 379
Images: 10
Re: Heater

I guess it does take time to get from 0-20C...The question is does it get eventually warm ? if yes,then heater is working..
Also, if your thermostat is not working,then your heat will also be erratic..
dafi166 is offline  
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: Heater

Electronic control of valve, and or air directional flaps, if the thermostat is functioning correctly?:
zulu ferret is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome