CD Shuttle magazine problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 29-12-08 Thread Starter
Status: -
AO Member
Bob222's Avatar
Join Date: Dec 2008
Location: South Africa
County: Gauteng
Posts: 21
Hmmm CD Shuttle magazine problem

Hi all,

My CD magazine refuses to eject from the shuttle. I doubt that I've broken the shuttle, as it was working just fine for a couple of days. The empty magazine jammed after I pushed eject and now makes no motorised sounds (i.e. zero attempts are made to load a CD on power-up or otherwise). Some of the CD shuttles in production have a protection mode that shuts down the whole shebang once a sequence fails to complete (I'm hoping it's that).

The radio still sees that there is a shuttle present.

1) Is there an easy/obvious fix I'm missing, that resets the shuttle electronics so that it at least tries to eject the magazine again (so I can jimmy it free)?

2) Is there a manual eject method, as might be found on computer CD-ROM drives?

3) Will I need a radio code if I unplug the shuttle plug(s)?

Thanks in advance!
Bob222 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jun 2003
Location: Surrey
Posts: 299

Member car:

166 V6 3.0

Re: CD Shuttle magazine problem

I've had the same problem, took it all apart to no avail. I tried Alfa dealers and Becker dealers, also no luck. Alfa UK suggetsed a local main dealer and offered to make sure they solved it (!?!) but I don't want to:
a. Lose the car for a day or two - they seem to think they need the car and that alone suggests that they don't know what they are doing.
b. Pay Alfa rates to get it fixed.

I bought a Loudlink MP3 and that's generally ok but I still want to get my CDs out of the old machine, perhaps I'll have another go.

mikealdren is offline  
(Post Link) post #3 of 6 Old 29-12-08 Thread Starter
Status: -
AO Member
Bob222's Avatar
Join Date: Dec 2008
Location: South Africa
County: Gauteng
Posts: 21
Re: CD Shuttle magazine problem

There is always the iPod and the Griffin RoadTrip FM transmitter to fall back on, but the Alfa lighter socket is pathetic; not a structural item; it will not hold the RoadTrip's stem properly.

One thing that I do remember when re-inserting the magazine was that it was unusually stiff. Nothing extreme, but stiffer than it was before (yes, it is the right way up!) Maybe the plastic rails that line up the magazine have derailed and jammed it in there... Will check once it's back from the cam-service.
Bob222 is offline  
Status: - Update
Posts: n/a
Re: CD Shuttle magazine problem

They're renowned for being fragile. You can get them repaired but more often than not they'll fail again not 6months later.

Best solution I've seen is the memory card reader that pretends its a cd changer. Can't remember the name of it off hand.
Status: Alfa-less :(
AO Gold Member
niallmoran's Avatar
Join Date: Oct 2003
Location: Dundee
Posts: 6,287

Member car:

'02 156 1.8 TS

Re: CD Shuttle magazine problem

loudlink is what you're thinking of chris

The mechanism is actually a sony so if it's knacked you can cannibalise a cheap and easy to get hold of old sony unit. My cart was stuck in both my changers but it's easy to fix - it's the push out mechanism that breaks but if you press eject and pull the cart at the same time (or use a screwdriver) it will come free...if you try this when it's switched off or a CD is loaded it will be locked in.
niallmoran is offline  
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
Re: CD Shuttle magazine problem

and Becker is German is it not (OK I know it is re-manufactured Sony, but that is hardly Italian either).

purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

magazine , problem , shuttle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome