Climate Control Fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 25-10-08 Thread Starter
Status: -
AO Member
Join Date: Oct 2007
Location: Warwickshire
Posts: 93
Hmmm Climate Control Fault

Can anyone shed any light on problems with 166 Climate Control.

Mine had a fault message come up and it's stopped working!!!
Had it checked over during 84,000 service and, sure enough, there are SEVERAL faults recorded. Garage thinks it may be an ECU fault possible due to water getting in. Is this likely?

It's booked in to have it sorted but I'd like to point them in the right direction to start looking if poss (after all it will cost 77 per hour for them to look, let alone fix)
HendersonR 166 is offline  
Sponsored Links
Status: "My other car'sa 166 TWO twice"
AO Gold Member
Pomeo's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: South Lanarkshire
Posts: 10,642
Images: 27
Re: Climate Control Fault


Loadsa info on here .


Stopped working....What?

no heat?
no cold?
no fan?

I reckon no fan

common problem

ERR...what were the faults recorded.

Pomeo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

climate , control , fault

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome