Rattling sound after air hose replacement - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 11-10-08 Thread Starter
Status: -
Join Date: Apr 2004
Location: Kidderminster, England
Posts: 4

Member car:


Rattling sound after air hose replacement

I have just had new air hose and airflow meter fitted to 166 2.0ts engine and on starting there is a rattling sound from that side of the engine. The sound is not rev related - any ideas?
Doubt if it is the cause but the mecahnic told me that he also reset the ecu.
adjuster is offline  
Sponsored Links
Status: -
Join Date: Oct 2008
Location: United Kingdom
County: West Midlands
Posts: 2

Member car:


Re: Rattling sound after air hose replacement

Check everything has been tightened back up correctly and that he has not left any tools in there )

If it cause is not obvious, I would definitely take it back to the mechanic.
rename is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

air , hose , rattling , replacement , sound

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome