'94 164 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 30-09-08 Thread Starter
Status: -
Join Date: Sep 2008
Location: United States
County: Florida
Posts: 2
'94 164

Hello everyone, This car was towed to my shop with the trans inoperative. I pulled the unit, a ZF4HP18Q, and rebuilt it, (the pump drive gear had split). After reinstalling I find that the unit is in failsafe. Moreover, there is no voltage at the solenoid connector on the trans. I am assuming that there is a fuse somewhere protecting this circuit, but it's not in the fuse block and I can't find its location using conventional sources. Can any of you supply that info? I'd like to avoid disassembling the car if possible. My sincere thanks for your help Clearman
clearman is offline  
Sponsored Links
Status: Stewart GP pic. due to milowokie and Eau Rouge
AO Platinum Member
In_The_Pass's Avatar
Join Date: Jul 2008
Posts: 12,405

Member car:


Re: '94 164

Clearman....sorry I can't give you the specific URL, but I came across a really good US Alfa site which had a whole thread on 164 Auto transmissions. I'll see if I can find it.

Hopefully an actual Alfa owner won't tell me, I was wrong and it was this site!

Is this any help:


Apologies if you've looked at those already.
In_The_Pass is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome