Boot Warning Light on 166 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-05-08 Thread Starter
Status: -
AO Member
Join Date: Apr 2008
Posts: 36
Boot Warning Light on 166

Hi Guys,

I know there is probably a thread already on here about this, but I can't find it.

My boot warning light keeps coming on telling me the boot is open when it's not.

Is this down to a faulty switch or dodgy electrics?

Also, my reverse lights do not work (bulbs checked and working fine), although the car had just passed an MOT before I bought it, and the interior boot light doesn't work.

Would this all be linked to the same thing or am I just unlucky with the arse on my car?

Any help would be appreciated.

charliet2001 is offline  
Sponsored Links
Status: 193K miles and still good.
AO Member
bww's Avatar
Join Date: Oct 2005
Location: France
County: Provence
Posts: 99
Re: Boot Warning Light on 166

I expect its the wiring from the back of the boot to the body below the rear window. This hardens and cracks with age and then shorts out in the black rubber tube where it bends each time the boot is open and shut.

I recently changed mine out by soldering in new wires and it cured all the problems.
bww is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

166 , boot , light , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome