TS tickover - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-04-08 Thread Starter
Status: -
AO Silver Member
Cream's Avatar
Join Date: Mar 2002
Location: wrexham
Posts: 1,278
Images: 2

Member car:

Brera 2.4SV

TS tickover

My TS feels likes its going to stall when coming to junctions, it never actually does it, but it starting to worry me

The rubber flexi hose and airfliter box was changed not long ago, all the clips are tight, so i dont think theres an airleak

Where is the idle control valve on these engines and does it require cleaning like the older TS engines ?
Cream is offline  
Sponsored Links
Status: -
AO Member
dex's Avatar
Join Date: May 2004
Posts: 90
Re: TS tickover

idle control valve is the metal cylinder on top of the engine at the back, infront of the plenum (on the 164 ts, anyway)

when the engine is up to normal operating temperature, if the idle is still dodgy (ie, the problem isn't just when cold/warm) then disconnect the plug going into the idle control valve and if the car idles properly then it needs cleaning/replacing.

If you disconnecting before up to temp it won't eliminate the valve - car will run though you'll need to keep your put down on the gas pedal slightly to stop it stalling. this will clear when up to temp to a hopefully normal idle.
dex is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome