Alfa 164 24v Super starting problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 28-03-08 Thread Starter
Status: -
Join Date: Jan 2007
Posts: 4

Member car:

Alfa 146 TI

Alfa 164 24v Super starting problem

Hi all, just bought this alfa and it will not start. It turns over but will not fire. There's no spark and I can't hear the fuel pump even when bridging the fuel pump relay.(checked the relay and it's fine) May try the wiring to the relay next though but doesn't look corroded at all.
It has not been used for some time so put new fuel in the virtually empty tank in case of dodgy old fuel. Just thought I'd ask if anyone's had the same problem or if this is a common issue and can point me in the right direction before getting the diagnostics on it. I don't think it's an immobiliser issue as when the remote fob arms the car the immobiliser does it's job and prevents the starter from turning at all. Many thanks
Discovolante is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Alfa 164 24v Super starting problem

Have very similar probs with mine now. Started as a misfire when hot. I am going to swap out the ign. amplifiers next. Fuel pump is virtually silent and always has been - I've got all that open too. It's really puzzling me.

Really tricky to check the ignition on this engine due to one bank covered up and the plug top coils. How did you do it?

Can't be much help on this atm, except to commiserate.

Oh and BTW, welcome to AO and great username.
Status: Medio Grigio AO Member
AO Member
Alfaomegatron's Avatar
Join Date: Mar 2008
Posts: 420
Images: 6

Member car:

164 1990 V6

Re: Alfa 164 24v Super starting problem

In case you did not receive an owners manual with your car, and I assume that the starting sequence is the same for the 24v as my 12v.

Cold Start - Fully press clutch pedal without pressing the accelerator etc.
Warm start - Fully press clutch and slightly press the accelerator.

Forgot the above couple of days back and no amount of turning the starter would start the car, 15 mins later returned left accelerator well alone and fired on first turn.

I hope its as simple as the above, good luck.
Alfaomegatron is offline  
(Post Link) post #4 of 4 Old 28-03-08 Thread Starter
Status: -
Join Date: Jan 2007
Posts: 4

Member car:

Alfa 146 TI

Re: Alfa 164 24v Super starting problem

Hi, thanks for the welcome and feedback guys. I checked the spark by simply pulling the coil and plug out of 2 cylinders(putting the plugs back in the coil female connectors of course) and turning the engine over to check for spark. I have an alfa specialist friend coming next wk to check so will give feedback then, hope it sheds some light on your problem too.
Discovolante is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

164 , 24v , alfa , problem , starting , super

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome