strange New Maf problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 14-03-08 Thread Starter
Status: -
AO Member
Join Date: Dec 2007
Location: Slovenia
County: -
Posts: 28
Images: 2
strange New Maf problem

So anyway after reading this and my national alfa forum i diagnosed that the problem with no power on my 166 super is maf related, i went out and bought one.

As i am na it expert and not a mechanic, i removed the old maf only to realise, that the new maf with its houseing does not fit. Later i found out it is probably for a 2.0TS motor. So i plug it in anyway and i fixate it so it only doesnt fall off during driving, i go for test drive. So the hose infront and after maf is quite open, not like it is supose to be, becose the maf doesnt fit.
So anyway car on the test drive flys like a rocket, i could bearly control it from taking of. I was used to a clinicly dead maf before .

Becose of lack of tools to remove the maf from the housing i left it be for the night and next day after work i went to a mechanic with used alfa spears. he put the maf in the right hosusing and sealed the sytem properly and when i take of, the car doesnt fly anymore! it is lots better then with old maf, but the power is again no there, not like on the test drive!

It is now couple of day later and i think the car is getting better, is that possible? but still not quite the same... dispite changing air filter a week ago, im now thinking it is not getting enough air, so im thinking of modifiing to sports filter...

any thoughts on my problem...?
Vesoljc is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

maf , problem , strange

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome