Clutch pedal issues? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 1 Week Ago Thread Starter
Status: Getting the full Alfa-experience
AO Member
 
Join Date: Nov 2014
Location: Denmark
County: -
Images: 4
Clutch pedal issues?

Hep!

When I get in the car in the morning/after it has been standing for a while, the clutch pedal is hard and not responding "in the top" but after the engine have run for a short time, the clutch acts more normal, but still hard.

Both cylinders are new, the clutch is new, and things are lubricated well.

1998 166 3.0 6-speed manual..

Any tips?
John Sahl is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 4 Old 6 Days Ago
Status: -
AO Member
 
DavidAlfa166's Avatar
 
Join Date: Apr 2013
Location: Spain
County: A Coruna
What about the arm in the gearbox, that is pushed by the slave cylinder?
Pretty common on JTDs, the bushing corrodes causing it to be hard when pressing down the clutch pedal.
DavidAlfa166 is offline  
(Post Link) post #3 of 4 Old 6 Days Ago Thread Starter
Status: Getting the full Alfa-experience
AO Member
 
Join Date: Nov 2014
Location: Denmark
County: -
Images: 4
Thanks for the tip, but that was removed, cleaned, and as far as I remember new bushings installed with lubrication.
John Sahl is offline  
(Post Link) post #4 of 4 Old 5 Days Ago
Status: -
AO Member
 
DavidAlfa166's Avatar
 
Join Date: Apr 2013
Location: Spain
County: A Coruna
Maybe the clutch pressure plate bearing, where it slides. Also pretty common, and usually causes that, soft the first minutes then gets harder.
DavidAlfa166 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

Tags
clutch , issues , pedal

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome