Water Leaks - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 24-01-08 Thread Starter
Status: Molto felice
AO Rosso Alfa Member
Gibbo's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: Bristol
Posts: 54,876
Images: 2
Water Leaks

Has anyone had any problem with water ingress in the front passenger area?
My carpet is sodden, particularly after heavy rain.
I've just been to Marshalls in Hitchin but they've not been able
to find the problem. They now want to remove the carpet to
have a butchers and reckon I'll be looking at at least three hours
labour just for that.
I hate paying for guess work
Anyone had a similar problem?
My immediate thought was the screen but Marshalls can't see any
sign of a leak there.
Gibbo is offline  
Sponsored Links
Status: Back in Black
AO Silver Member
Dougie166's Avatar
Join Date: Aug 2006
Location: United Kingdom
County: Clackmannanshire
Posts: 4,103
Images: 9

Member car:

Alfaless :( BMW!

Re: Water Leaks

My first thought would be a blocked drain pipe - have a feel about for drain pipes down back of engine at bulkhead and see if clear. These pipes take water away that runs through plastic venting at base of windscreen, they could get blocked with sludge/leaves. This area would then fill up with water causing water ingress through heating vents.

Alternatively there may be a leak in coolant system - Does the damp area have a sweet smell or taste?
Dougie166 is offline  
Status: -
AO Member
Join Date: Jul 2006
Location: Dublin
Posts: 76

Member car:

166 Super

Re: Water Leaks


I have had this problem, and as far I know, the source of the ingress is from the area forward of the cabin bulkhead just beneath the bonnet. (ie. the area where the wiper motor sits, or cabin air intake plenum).
I believe that the water was getting in when the car was washed, and in my case was soaking the rear carpet also.

Two thoughts;

1 There is a drain from this area, my specialist unblocked it with a long screwdriver, with the undertray removed.

2 Are you running without the underbonnet plastic trims attached?
I was, and I believe that the rearmost plastic guard keeps a lot of water from entering that plenum.

Anyway, since I had the drain cleared, and replaced the trim, I have had no recurrence, however I haven't washed the car recently!

Will update soon.


Regards, Simon.
SimonR is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

leaks , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome