Vibration - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-01-08 Thread Starter
Status: -
AO Member
Join Date: Feb 2002
Location: Finchampstead
Posts: 167

I guess I count as newbie on this part of the forum, having acquired low (68k) miler clean 166 2.0 TS in dark blue earlier today to add to the high (149k) miler 155 2.0 TS (what a car) and 156 SW on the drive (and on their respective fora).

Test drive didn't get up to motorway speeds around North London so vibration at 80mph or so on run home needs a look. I haven't checked tyre pressures as yet (but will) and guess the best course is to get alignment, tracking etc looked at but wondered if the established drivers of the model had any thoughts.....

HNY all
jrec149 is offline  
Sponsored Links
Status: -
AO Member
vivian166ti's Avatar
Join Date: Feb 2007
Location: United Kingdom
County: Warwickshire
Posts: 788

Member car:

SAAB 9-5 2.3t

Re: Vibration

get wheels balanced first,sometimes wheels out of balance only
show up at certain speeds and can be driven through.
another common cause of speed related vibration
is the tyres themselves,so well worth getting these checked at the
same time,had an old merc. s class a while ago and changing the
front tyres and balancing completely cured the problem.
vivian166ti is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome