159 with whirring noise when unlocking - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 27-06-16 Thread Starter
Status: -
AO Member
Join Date: Apr 2011
Location: United Kingdom
County: Northamptonshire
Posts: 11

Member car:


159 with whirring noise when unlocking

Hi all. I'm looking for some help with what i'm hoping is a small problem with my 159... everyone loves a good mystery so here's the background...
so, a while ago the drivers' window regulator failed. I'd been putting the job off until the weather was better and successfully changed it about a month ago (or so i thought...). Unbeknownst to me, there was a rubber bung where the wiring comes through the door panel that i must not have put back correctly as this was getting caught when the window was coming down and causing too much ampage to be pulled by the mechanism which was taking out the fuse... which also controls the steering lock and key recognition which caused about an hours worth of panic while i worked out what i'd done!!
Anyway, I had just finished putting the door back together and tested everything was working. I was just walking away from the car when it started to make an uncontrollable whirring noise which seemed to be coming from the fuel tank... keys were out, car was locked, absolutely nothing was happening - other than this noise which had started all on it's own from out of nowhere!!
The only way to stop it was to disconnect the battery but whenever i reconnected it, the noise would start again. I backtracked what i did and took the fuse out for the windows and steering lock which stopped the noise, so now i am confident it's something to do with the locking mechanism rather than the fuel pump or something like that. There is a small black box located on the inside of the drivers door with a circuit board inside (just above the window regulator motor - i have no idea what this is but i assume it's some sort of ECU??) that has 3 connectors on it - when i remove the white block going in to it, the noise stops - put it back and the noise comes back... but now only for half a second then stops.
Now everything is back together, the noise happens only when unlocking the car. I can open the boot without the noise happening and if i stick my head in and unlock the car, the noise is clearest on the right hand side.
All the doors lock and unlock as they should, i just now have this mechanical whirr for half a second when unlocking which sounds really horrible... has anyone else experienced this and have any idea what it is please - it's driving me insane!!
159Lee is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , noise , unlocking , whirring

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome