159 help. . - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 3Likes
  • 1 Post By sketchy19
  • 1 Post By Mr Flibble
  • 1 Post By Larry92
 
Thread Tools
(Post Link) post #1 of 15 Old 27-06-16 Thread Starter
Status: -
AO Member
 
robsterj's Avatar
 
Join Date: Nov 2013
Location: United Kingdom
County: Shropshire
Posts: 63

Member car:

ALFA 159 JTDM Ti

159 help. .

HELP! I have a poorly 159 and not sure where to start?.

1, turbo whistle rather loud. Check pipes, slight stretch on intercooler bottom hose which needs replacing but can't find OEM or silicone replacement. Alfa will only supply with aluminium pipe from rear of turbo.

2, smoking from rear and loss of power, had terraclean to clear deposits from engine and DPF , also cleaned the mass flow sensor.

3, knocking from front nearside wheel. Replaced top upper wishbone and everything fine for couple of days now back with a vengeance although more like a creaking flex noise when accelerating and braking or car leaning into bend.

Any advice greatfully accepted
robsterj is offline  
Sponsored Links
Advertisement
 
Status: Mulling over Guilia replacement for 159
AO Member
 
Join Date: May 2007
Location: United Kingdom
County: Essex
Posts: 22
Garage
Hmmm

I have just started a similar thread with point #3.

It's weird that mine is intermittent. Is yours constant with every bonnet dip from breaking ? If I go and break heavily to reproduce it nothing happens. But then randomly, on a tight left turn or even a not particularly harsh break to come to a stop, it clonks.
Cacker is offline  
Status: -
AO Member
 
Join Date: Oct 2012
Location: United Kingdom
County: North Yorkshire
Posts: 86
Quote:
Originally Posted by Cacker View Post
I have just started a similar thread with point #3.

It's weird that mine is intermittent. Is yours constant with every bonnet dip from breaking ? If I go and break heavily to reproduce it nothing happens. But then randomly, on a tight left turn or even a not particularly harsh break to come to a stop, it clonks.
You could check main air intake to pipe to/from resonator & where it attaches to turbo itself? any oil residue where it attaches to turbo cold side?
Have you checked Swirl Flap actuation/is it attached?
First port of call would be the side you had the wishbone changed ensuring it is all back together as it should have been.
Have you checked the drop links? Main rear lower wishbone bush? (where it joins sub-frame)
Paul777 is offline  
 
(Post Link) post #4 of 15 Old 27-06-16 Thread Starter
Status: -
AO Member
 
robsterj's Avatar
 
Join Date: Nov 2013
Location: United Kingdom
County: Shropshire
Posts: 63

Member car:

ALFA 159 JTDM Ti

Quote:
Originally Posted by Cacker View Post
I have just started a similar thread with point #3.

It's weird that mine is intermittent. Is yours constant with every bonnet dip from breaking ? If I go and break heavily to reproduce it nothing happens. But then randomly, on a tight left turn or even a not particularly harsh break to come to a stop, it clonks.
Hi, yes some days worse than others. Sounds like car is flexing when turning into bend braking or accelerating. But if I bounce the car up and down no nock. Worse a slow speeds.? Very bizarre.
robsterj is offline  
(Post Link) post #5 of 15 Old 27-06-16 Thread Starter
Status: -
AO Member
 
robsterj's Avatar
 
Join Date: Nov 2013
Location: United Kingdom
County: Shropshire
Posts: 63

Member car:

ALFA 159 JTDM Ti

Quote:
Originally Posted by Paul777 View Post
You could check main air intake to pipe to/from resonator & where it attaches to turbo itself? any oil residue where it attaches to turbo cold side?
Have you checked Swirl Flap actuation/is it attached?
First port of call would be the side you had the wishbone changed ensuring it is all back together as it should have been.
Have you checked the drop links? Main rear lower wishbone bush? (where it joins sub-frame)
will take a look.
robsterj is offline  
Status: Still engineering
AO Silver Member
 
Old Engineer's Avatar
 
Join Date: Mar 2003
Location: Esher
County: Surrey
Posts: 2,095
Images: 12
Quote:
Originally Posted by robsterj View Post
Hi, yes some days worse than others. Sounds like car is flexing when turning into bend braking or accelerating. But if I bounce the car up and down no nock. Worse a slow speeds.? Very bizarre.
If it's been tightened up with the suspension fully dropped then it will pre stress it in the unloaded condition. I'd undo everything then compress the suspension to normal ride height before torquing up the bolts again.
Old Engineer is offline  
(Post Link) post #7 of 15 Old 28-06-16 Thread Starter
Status: -
AO Member
 
robsterj's Avatar
 
Join Date: Nov 2013
Location: United Kingdom
County: Shropshire
Posts: 63

Member car:

ALFA 159 JTDM Ti

Quote:
Originally Posted by Old Engineer View Post
If it's been tightened up with the suspension fully dropped then it will pre stress it in the unloaded condition. I'd undo everything then compress the suspension to normal ride height before torquing up the bolts again.
will try that too.
robsterj is offline  
(Post Link) post #8 of 15 Old 12-07-16 Thread Starter
Status: -
AO Member
 
robsterj's Avatar
 
Join Date: Nov 2013
Location: United Kingdom
County: Shropshire
Posts: 63

Member car:

ALFA 159 JTDM Ti

Update on car,.
Knocking was failed bush on new wishbone, so have a had replacement sent.
Cleaned Maf ,map sensor and swirl valve. Very dirty but not cured smoke issue. However i imagine EGR will be heavily soiled too. Very difficult to access on 2.0 jtdm ,not sure how to take apart.
Whilst driving on motorway I lost complete turbo pressure and drove home with no turbo. Pressure returned and turbo boosting again but power down. Think lower intercooler hose has split even thou had recently repaired with silicone tape. Waiting for results on turbo, alfa dealer have sent it away for testing. ..:depressed
robsterj is offline  
Status: -
AO Member
 
sketchy19's Avatar
 
Join Date: Aug 2013
Location: UK
County: South East
Posts: 88
EGR clean is not to bad. I just did it on my 2.0 jtdm and used these instructions took about an hour.

https://www.vxoc.org.uk/forum/Thread...TLE-BODY-CLEAN

Egr Sticking Caused turbo fault code and no pressure. Have a look at my post here

http://www.alfaowner.com/Forum/alfa-...-no-turbo.html (Urgent help needed Oh No Turbo???)

Hope it help
robsterj likes this.
sketchy19 is offline  
Status: -
AO Member
 
Join Date: Dec 2007
Location: United Kingdom
County: Derbyshire
Posts: 271
Images: 15
Garage
Quote:
Originally Posted by robsterj View Post
Update on car,.
Knocking was failed bush on new wishbone, so have a had replacement sent.
Cleaned Maf ,map sensor and swirl valve. Very dirty but not cured smoke issue. However i imagine EGR will be heavily soiled too. Very difficult to access on 2.0 jtdm ,not sure how to take apart.
Whilst driving on motorway I lost complete turbo pressure and drove home with no turbo. Pressure returned and turbo boosting again but power down. Think lower intercooler hose has split even thou had recently repaired with silicone tape. Waiting for results on turbo, alfa dealer have sent it away for testing. ..:depressed
How did you clean the MAF? I'm no expert but I thought cleaning it was a no no, as residues are left behind compounding the issue.

The split in the hose I'd say is the cause of the black smoke, escaping boot pressure will cause overfueling resulting in a dirty burn.
robsterj likes this.

Last edited by Mr Flibble; 12-07-16 at 22:22.
Mr Flibble is offline  
Status: -
Club Member
Membro Premio
 
Join Date: Apr 2016
Location: Bristol
County: Avon
Posts: 272
with the turbo issue - are you sure its an air whooshing sound? I thought mine sounding like a whooshing but turned out in fact to be a worn/about to give up bearing in the actual turbo.....
Larry92 is online now  
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
 
giblets46's Avatar
 
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,319
Garage
Fitting the EGR blanking plate on the 159 2.0JTDM is identical to the Giulietta Including removing parts from the Bulkhead, see my guide below:

http://www.alfaowner.com/Forum/alfa-...-to-guide.html (EGR Blanking Plate - How to Guide)
giblets46 is offline  
(Post Link) post #13 of 15 Old 21-07-16 Thread Starter
Status: -
AO Member
 
robsterj's Avatar
 
Join Date: Nov 2013
Location: United Kingdom
County: Shropshire
Posts: 63

Member car:

ALFA 159 JTDM Ti

Quote:
Originally Posted by Mr Flibble View Post
How did you clean the MAF? I'm no expert but I thought cleaning it was a no no, as residues are left behind compounding the issue.

The split in the hose I'd say is the cause of the black smoke, escaping boot pressure will cause overfueling resulting in a dirty burn.
You can buy specialist cleaner that leaves no residue. .

Look at this on eBay http://www.ebay.co.uk/itm/221424255723
robsterj is offline  
(Post Link) post #14 of 15 Old 21-07-16 Thread Starter
Status: -
AO Member
 
robsterj's Avatar
 
Join Date: Nov 2013
Location: United Kingdom
County: Shropshire
Posts: 63

Member car:

ALFA 159 JTDM Ti

Looks like I need a lower intercooler hose, however can't buy OEM without aluminium pipe from rear of turbo which is costly. Tried looking for silicon hoses but no good. Specialist could make but costly again as it reduces in size from 60 mm ID to 45 mm ID.
Any ideas where I can purchase pipe only? .....
robsterj is offline  
Status: -
Club Member
Membro Premio
 
Join Date: Apr 2016
Location: Bristol
County: Avon
Posts: 272
Quote:
Originally Posted by robsterj View Post
Looks like I need a lower intercooler hose, however can't buy OEM without aluminium pipe from rear of turbo which is costly. Tried looking for silicon hoses but no good. Specialist could make but costly again as it reduces in size from 60 mm ID to 45 mm ID.
Any ideas where I can purchase pipe only? .....
Call Autolusso - Liam is in the parts department - they are an alfa breaker amongst other things so they may well have the part you need i got my replacement turbo from them
robsterj likes this.
Larry92 is online now  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
159

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
Replace with
For the best viewing experience please update your browser to Google Chrome