159 immobilised - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By 159Lee
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 24-06-16 Thread Starter
Status: -
AO Member
Join Date: Mar 2015
Location: Ireland
County: Limerick
Posts: 11

Member car:

Alfa 159

159 immobilised

I recently took a trip to a local beach for the day, returning to the car to find it wouldn't unlock.
Long story short, ended up having to get it towed to a auto lock smith for an assumed key reprogramming.
After nearly a week I got the car back. New ecu, programmed key, steering lock mechanism and clocks?
Now have no hill hold, vdc traction control or abs. My auto lights don't work and just today a check engine light too. The day after I got the car I took it to my mechanic for a diagnostic check and all the parts the lock smith put in, it seems nothing was calibrated, going back next week for him to look at it but when I called him, he said as long as it starts then he has done his part. How does that sound?
Do you think the check engine light is possibly related to the recent work or something new, I have a wedding this weekend so that's why I haven't brought it back yet.
Jack 159 is offline  
Sponsored Links
Status: All Hell's A-Coming
AO Platinum Member
Tata4Now's Avatar
Join Date: Sep 2009
Location: France
County: Riviera
Posts: 26,944
Sounds like a battery issue.

Jump starting could lead to you needing everything reset.
Tata4Now is online now  
Status: turning heads everywhere
AO Silver Member
lussoman's Avatar
Join Date: Feb 2007
Location: Preston
County: Lancashire
Posts: 3,935
A bit late now, but presumably it wouldn't unlock with the metal key (concealed within the key fob) either, not just the button on the key fob?
I'm absolutely staggered all that expensive work's been done. New ECU??!
Please tell me they did thoroughly test the battery as a first move?
lussoman is offline  
(Post Link) post #4 of 6 Old 26-06-16 Thread Starter
Status: -
AO Member
Join Date: Mar 2015
Location: Ireland
County: Limerick
Posts: 11

Member car:

Alfa 159

The battery was showing the correct output and so was the battery in the key. The key blade opened the car but the alarm kept going off when I got in. Couldn't jump start it or push/pull start it, steering lock kept engaging. I'll be bringing it back this week so will hopefully get some good news on this subject.
Jack 159 is offline  
Status: -
AO Member
Join Date: Dec 2009
Location: Netherlands
County: Zuid Holland
Posts: 213
Proxy alignment needed?
Jerry 159 is offline  
Status: -
AO Member
Join Date: Apr 2011
Location: United Kingdom
County: Northamptonshire
Posts: 11

Member car:


I'm almost reluctant to post this but I had the exact same problem on my 159 a week ago after it had been in the workshop for a week. I got the car home, removed the key to go and move my wife's car off the drive and when i went back to mine, Vehicle Protection System not available and neither the master or spare key were recognised.
Luckily, got the RAC out to it (other motoring breakdown firms are available) and the guy was absolutely excellent - spent over an hour on the problem and tracked it to a blown fuse in the box under the steering wheel (the fuse in question was i think F31 and controls the steering lock and the electric windows, which it turned out were pulling too much current for the 15 amp fuse and had blown it). replaced the fuse (and fixed the window regulator which was causing the issue) and everything has been fine since.
lussoman likes this.
159Lee is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , immobilised

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome