Alfa 159 2.4 JTDM Oil Pressure Low/High? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 23-06-16 Thread Starter
Status: -
AO Member
jazman27's Avatar
Join Date: Jan 2015
Location: United Kingdom
County: Glasgow
Posts: 29
Hmmm Alfa 159 2.4 JTDM Oil Pressure Low/High?


About 6 weeks ago my 159 (Ti) started beeping that the oil pressure was too low (at low revs and whilst accelerating).

It's been driving fine except every time it keeps beeping with low oil pressure on acceleration.

It doesn't beep when NOT under load. You can rev the engine as much as you want and it's fine. It ONLY beeps when you actually start driving it.

I've changed the OIL, Oil filter, and oil pressure sensor. Still the same problem.

So I've taken it into CM Garage (Alfa specialists in Glasgow), they ran an oil pressure test and they have said the oil pressure is too high! Far too high.

The car says the oil pressure is too low, the test says it's too high. WTF??

Nobody knows what could be the problem - any ideas?
jazman27 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , alfa , jtdm , low or high , oil , pressure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome