New Owner's 159 Questions - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 18-12-07 Thread Starter
Status: -
hartleyj's Avatar
Join Date: Nov 2007
Location: Beaconsfield
Posts: 9
New Owner's 159 Questions

So I finally got my first Alfa last week. So 600 miles on the observations are:

1. Great motor. Lovin' it!

2. First trip to the parts dept about 2 hrs after taking delivery - wiper blades (Halfrauds don't sell them?).

3. 600 miles on, and admittedly the weather's ****, but the front lights are completely caked in dirt. Design over function maybe? Anyone tried RainX or any other solutions?

4. Service intervals. I was told 18000 miles but the service handbook says 12000. The car's on 11600 so need to resolve this one soon....

5. Consumption hovering around 36mpg. Mainly motorway at 70-80. but might I have expected more?

Any advice gratefully received.

hartleyj is offline  
Sponsored Links
Status: frenzied burrowing
AO Platinum Member
Fraser's Avatar
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Images: 8
Re: New Owner's 159 Questions

1. No surprise there then

2. Did you buy from a dealer? If so you should have asked them to replace the blades.

3. In all the cars I've owned that's been a problem.

4. 18,000 mile interval.

5. Fuel consumption seems to be poor - I'm getting 30 mpg Although my journeys are short urban jaunts mostly.

Welcome to the forum BTW.
Fraser is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
Re: New Owner's 159 Questions

welcome to AO

mpg is good mate - I am like Fraser - 30-32 mpg from a tank - oh well.........

my wipers have started to judder - 17k on the car

had my 18,000 service when I got the car at just over 15,000 miles.
dpat is offline  
Status: Wondering why people buy so many Audis
AO Silver Member
Quadrofoglio's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: West Yorkshire
Posts: 1,225
Re: New Owner's 159 Questions


No probs with the lights or wipers - which are normally pretty long lasting on Alfas I have found.

Suggest you check the service interval with your dealer. They all seem to say something different. Had mine done at a year/10k regardless.

Get 26mpg from the 2.2 petrol so 36 on a diesel looks fine to me!
Quadrofoglio is offline  
Status: Breraless :(
AO Platinum Member
Squadrone Rosso's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,893
Images: 45
Re: New Owner's 159 Questions

Moved to the 159 lounge
Squadrone Rosso is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , owner , questions

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome