hid help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-05-16 Thread Starter
Status: -
AO Member
corasdad's Avatar
Join Date: Dec 2015
County: -
Posts: 159
hid help

after following another members hids thread i to bought some hid's, but i had constant error messages or only one light would power up till i turned them off and on again , this started to annoy me and i ended up sending them back!
I have been emailing another company who say their system will work, does anybody have any dealing with these lights, and they also say i should be using 35w rather than 50w would there be much differance in ligh output?

these are the lights

these are the lights i 1st bought that didnt work on my car

any help or advice would be great thanks Graham

corasdad is offline  
Sponsored Links
Status: Angel tuned tyre burner
AO Silver Member
Alfa.Romeo's Avatar
Join Date: Mar 2009
Location: United Kingdom
County: Kent
Posts: 2,124
I fitted the kit type linked below, the larger metal type box one. I've had it on about 4 years without issue, and have also fitted capacitors to keep error codes away. I use 55w ones, and that's what I'd advise you to fit as works great for me.


Alfa.Romeo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome