Boot metal tab (Spider) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 10-05-16 Thread Starter
Status: turning heads everywhere
AO Silver Member
lussoman's Avatar
Join Date: Feb 2007
Location: Preston
County: Lancashire
Posts: 3,931
Boot metal tab (Spider)

Anyone else had a problem with the metal tab that's part of the boot lock?
Mine seems to stick in the middle position (as shown in the pic) every now and again, I need a screwdriver to prise it across to the far right where it should be.
If it's in the middle the boot won't close.
I think water ingress is the problem - the trim on the underside of the boot lid is always wet through, as though water is somehow bypassing the thick rubber seal that surrounds the top of the boot area.
I've given the lock mechanism a good spray with GT85, but not convinced it's helped.
Attached Images
File Type: jpg P1020109.jpg (55.0 KB, 7 views)

Past: GTV T.Spark Lusso (owned 8 years) Present: 948 Spider LE (bought Nov. '10) Future: 8C (in my dreams )
Previously (selective): Porsche 944 Turbo; Porsche 944S; Jaguar XJ6; Audi Coupe; Mark 2 Golf GTI.
lussoman is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

boot , metal , spider , tab

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome