How did that happen - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-05-16 Thread Starter
Status: -
Join Date: Jun 2015
County: -
Posts: 2
Hmmm How did that happen

Hi all
My Brera has recently had a new timing belt (which was needed) to cure a prolonged misfire and wobble felt at around 1500 rpm, short while later problem returned, changed plugs and coil pack, no change engine light back on and wobble continued. Ordered replacement fuel injectors as final hope to resolve engine light, misfire and poor economy when ....... Reversing car in a hurry managed to stall, then restart asap as in middle of road and guess what no engine light and miss fire apparently gone, haven't had chance to really check fuel economy but what on earth has caused this recovery. Any ideas please let me know, thanks. Chris
Greatscott is offline  
Sponsored Links
Status: Returning a gtv toformer glory
Club Member
Membro Premio
alfaholik's Avatar
Club Member Number: 401
Join Date: Apr 2008
Location: United Kingdom
County: Mid Glamorgan
Posts: 1,095
Images: 1
You should have the fault code read. Then you'd know what was going on perhaps?
alfaholik is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome