Is this common? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 29-04-16 Thread Starter
Status: My first Alfa and loving it!
AO Member
blueblood1995's Avatar
Join Date: Aug 2014
Location: Australia
County: Victoria
Posts: 196
Is this common?


I have a 2010 159 JTD Ti and wanting to know if paint delamination on the 159 roof rails is a common problem?
Refer to attached photos.
Perhaps this was a problem on some models only?

Refer to the attached photos showing paint issues.
Only the x4 end sections are a problem. I have been told these are plastic, whereas the main rail is aluminium.

Thanks in advance
Attached Images
File Type: jpg IMG_3248.jpg (55.0 KB, 31 views)
File Type: jpg IMG_3250.jpg (48.3 KB, 28 views)
File Type: jpg IMG_3249.jpg (81.8 KB, 25 views)
blueblood1995 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Dec 2012
Location: United Kingdom
County: Cambridgeshire
Posts: 11
My 56 Plate is the same.
svcabr is offline  
Status: Fingers crossed no more expense.
AO Member
Waquer159's Avatar
Join Date: Nov 2012
Location: United Kingdom
County: Devon
Posts: 290
Seems to be my 08's the same.
Waquer159 is offline  
Status: -
AO Member
Join Date: Sep 2014
County: Cheshire
Posts: 79
yep - ends and rails
tenuta is offline  
Status: 16Italiancylinders(V 6,N4,L2,V2,V2)+1Span ish
AO Silver Member
swq4's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 1,507
Images: 28
Mine the same - was going to get them matched to the Gunmetal wheels but too much faff with them being different material
Slowly polishing them with autosol to bring them all to the same hue
swq4 is offline  
Status: -
AO Member
Join Date: Sep 2007
Location: United Kingdom
County: Hampshire
Posts: 174

Member car:

Alfa GT V6

Yes. Our 10 plate Ti had flakey rails so we got them repainted as part of the purchase deal. Make sure the caps on the central mount are removed very carefully as the securing tabs break easily. We lost one so had to order new - they were only about £14 each delivered from Italy to the stealer and either came in black or silver...
mjaz101 is offline  
Status: !59 Ti -black boost bus
AO Member
jatkinson's Avatar
Join Date: May 2014
Location: United Kingdom
County: Cumbria
Posts: 49
My 60 plate is the same
jatkinson is offline  
Status: -
AO Member
Join Date: Nov 2008
Location: United Kingdom
County: Leicestershire
Posts: 13
Yep mine to 😡
chris1956 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome