159 ti Glow plug relay problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 07-03-16 Thread Starter
Status: -
Join Date: Mar 2016
County: -
Posts: 2
159 ti Glow plug relay problems

Hi all, newbie here to AO and to Alfa ownership.

Bought myself a 159 ti with 69k on the clock and have been sorting out a few issues. My current one is I need a Glow Plug relay ... but don't want to pay Alfa 107 for the privilege. I have a picture of it with 2 numbers, neither of which are giving me joy on eBay. They are; v23136-a1001 and 60698861.

Can anyone point me in the direction of the right part number and advice on where to buy? (If not eBay). Picture of it attached.

Also having issues with the dpf, it's regenerating every 100 - 150 miles or so. Could be related to glow plug issue? I have replaced the plugs already. Maybe looking at removal and remapping so this should sort it anyway I hope...

Thanks all
Attached Images
File Type: jpg image_1457367183065.jpg (37.6 KB, 13 views)
Shanks79 is offline  
Sponsored Links
(Post Link) post #2 of 3 Old 07-03-16 Thread Starter
Status: -
Join Date: Mar 2016
County: -
Posts: 2
It's the relay located underneath the fuse box if that helps...?

Shanks79 is offline  
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,198
Try someone breaking a 159, should be able to source one for you

Any spelling/ grammatical errors are purely there to annoy!
giblets46 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , glow , plug , problems , relay

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome