Thud, power steering gone and battery sign on HUD - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 29-02-16 Thread Starter
Status: -
AO Member
Join Date: Jan 2006
Posts: 67

Member car:

156 GTA

Thud, power steering gone and battery sign on HUD

Went to get the car washed, noticed there was a slight burning smell and a little bit of smoke coming from the drives side front.
Driving home heard a bang, and the power steering stopped working car was running as normal. The battery sign has come up on the head up display.

Im guessing its a tensioner or something thats gone?
babylaal is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Jul 2004
Location: United Kingdom
County: Derbyshire
Posts: 5,583
The thud you heard was the auxiliary drive belt making its bid for freedom!

The belt drives the power steering pump & the alternator, which explains the loss of power steering & the battery light.
Dave Brand is offline  
Status: On a Mission.
AO Member
Join Date: Dec 2009
Location: United Kingdom
County: Buckinghamshire
Posts: 825
Assuming that you are talking about a 159 diesel, the most likely explanation is crankshaft (damper) pulley failure. This is quite common with these cars. A word of advice if this is the case: use only Dayco or genuine replacement pulleys.
FoxtrotOscar is offline  
Status: -
AO Silver Member
alcooker's Avatar
Join Date: Sep 2008
Location: Hitchin
County: Hertfordshire
Posts: 1,914
Must be the season for it, this happened to my wife yesterday. Was a bottom pulley that had come off, 220 for a new one supplied and fitted and a good check over of the car. Very relieved it wasn't a steering rack melt down.
alcooker is offline  
Status: -
AO Member
Norph's Avatar
Join Date: May 2015
Location: Buckinghamshire
County: United Kingdom
Posts: 110

Member car:

159 SW Ti 2.4

+1 to the above two.

Happened to me about 6months ago. (Mine's s 2.4)

Sent from my HTC One_M8 using Tapatalk
Norph is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,609
Changed a couple of these in the last year. Not uncommon.
Pud237 is offline  
Status: -
AO Member
Join Date: Aug 2015
County: -
Posts: 24

Member car:

Alfa 159

crankshaft pulley failure - happened to me too.
burning smell, loss of PS and aircon stops working.

rubber parts rubbing against each other hence creating burning smell.
quite an easy job to do. paid 150 pounds for parts.
supergrusha is offline  
(Post Link) post #8 of 8 Old 01-03-16 Thread Starter
Status: -
AO Member
Join Date: Jan 2006
Posts: 67

Member car:

156 GTA

Garage just confirmed its the Crank Shaft Pulley
140 for parts
babylaal is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

battery , hud , power , sign , steering , thud

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome