159 tbi 1750 sw front vibration - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-02-16 Thread Starter
Status: -
Join Date: Feb 2016
County: -
Posts: 1
159 tbi 1750 sw front vibration

Hello everyone, please help?

i have bought a 159 tbi 1750 sw 2011, and everything seemed to be in good shape, but then in a very short while i started noticing a viration in the front of the car. I probably didn't notice it at once because i didn't know the car yet.

The vibration is sometimes on the right side and then sometimes on the left side. Never on the same side at once. Sometimes it feels like the vibration is close to the middle of the car around the gearbox/clutch area.

The car has followed all the services and seem to be in very nice shape,except for this problem. I talked to an Alfa mechanic and he suggested that i should change the drive shafts, i did on both sides, but that didn't help......

The vibration is only there when i let go of the gass pedal... When i push the gass pedal again it is gone. Very strange.

So in short, the vibrations start when i let go of the gass pedal, when decelarating, usually between 2800-2000rpm

Please help me if you have some ideas on how to solve this problem
william76 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , 1750 , front , tbi , vibration

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome