946 Spider 'Hood mechanism failure' - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 2 Post By lussoman
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-02-16 Thread Starter
Status: -
Join Date: Feb 2016
Location: London
County: -
Posts: 1
946 Spider 'Hood mechanism failure'

Hi all, I'm new to the forum having just got my 08 Alfa Spider a couple of weeks ago.

I've searched the threads for Spider hood issues, but can't find any that quite match the problem I'm having.

Before I got the car, I tested the hood a number of times, it opened/closed smoothly with no issues.

After getting the car, one of the first things it needed was a new battery. After changing that, I had some problems getting the windows to close properly but found a way to reset them ok.

This morning I've tried the hood for the first time since I got the car home, and I'm getting the message 'Hood mechanism failure' seconds after pressing the button. The windows go down fractionally, but nothing else happens. Pressing the button up or down has no effect. After leaving it a few minutes, taking the key in and out (I can't remember the exact sequence), eventually pressing the up button closes the windows, and the message 'Hood operation not complete' appears.

I suspect (hope) there might be something I need to do reset something in relation to the battery change.

Has anyone had a similar issue, and if so how did you resolve it?

Many thanks
Marooned is offline  
Sponsored Links
Status: turning heads everywhere
AO Silver Member
lussoman's Avatar
Join Date: Feb 2007
Location: Preston
County: Lancashire
Posts: 3,951
Let the 'roof anxiety'commence...
When you have the roof down, dark clouds are threatening and you get the dash warning message when trying to raise the roof - now that is serious squeaky-bum time.

My only advice is to get used to moving the roof manually.
Hopefully you'll never have to do the whole process manually but at least get to know the procedure.

I'm sure every Spider owner must have seen error messages by now.
Jchan11hk and SpiderSaint like this.
lussoman is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

946 , failure , hood , mechanism , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome