946 spider has me completely stumped - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 09-02-16 Thread Starter
Status: -
Join Date: Aug 2015
County: -
Posts: 5
946 spider has me completely stumped

Hi everyone,

I have a 2009 2.4 spider and it's developed some real problems. Last week I got a warning saying that the DPF filter was blocked, but I drove on a long run from Hereford to Manchester and back, and it disappeared. Then, on my way to work last Saturday it went into limp mode, and every time I restarted it would clear but come back within around half a mile. It did the same on the way home, and then it finally stalled about half a mile from home. I managed to start it and just about it limp it , but it didn't sound good and had no guts whatsoever. I read a few forums and the advice seemed to be that it was either a low powered battery, a dirty EGR or a blocked DPF filter.
So, I got a new battery and I cleaned out the EGR, but neither made any difference. Now though it won't start at all. After maybe 12-15 attempts it will cough to life for about a minute but then stall again, but when it does run it sounds really rough and it blows out a LOT of white smoke. We've plugged in a diagnostics jobber, but all that's on there is the DPF warning. This clears but then comes up again when you finally get it to run briefly. I rang a local garage but they said whatever the problem is, it isn't the filter. Does anyone have any experience with this or know what the cause may be? Thank you in advance for any help, and sorry for the essay!


By the way, it's not down to me putting petrol in, and a mechanic mate is confident the head gasket hasn't gone.
hammondsenior is offline  
Sponsored Links
Status: -
AO Gold Member
Wezley's Avatar
Join Date: Sep 2011
Location: United Kingdom
County: Greater Manchester
Posts: 11,402
Images: 27

Member car:

159 2.4 JTDm

Sorry no ideas but curious myself. I don't have a problem but the DPF does concern me a bit on modern diesels.
Wezley is offline  
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,202
946 spider has me completely stumped

DPFs do have a finite life span, so it could just be past it, but worth checking the temp and pressure sensors, other users have had theirs fail (the pressure sensor has a rubber tube that can perish, have a look at the readings when it's plugged in.

It could also be related to other problems if it's been running rich, or the egr has not been working it can cause it to soot up,
Try the diesel power loss guide in the stickies , a few suggestions that you can at least rule out then

Sent from AutoGuide.com Free App[/color

159 1.9JTDM Ti and Giulietta 2.0 Veloce
ex: Punto 55s, Golf Mk5 1.4FSi, A3 (8P) Sportback 2.0TDi SE, A4 (B8) 2.0TDI S-Line, 306 HDI Meridian

Last edited by giblets46; 10-02-16 at 17:29.
giblets46 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

946 , completely , spider , stumped

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome