Alfa 159 passenger side wiper broken... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 04-02-16 Thread Starter
Status: -
AO Member
Join Date: Feb 2016
County: -
Posts: 20
Alfa 159 passenger side wiper broken...

Hi, I'm having an issue with my Alfa 159, the passenger wiper arm suddenly gave up as I was driving home - the driver's side wiper is still working. I've had a look around the forum for a solution but I couldn't find anything which exactly fits my issue. I haven't inspected the wiper motor and assembly as it's nighttime but I feel like one of the bolts that connects the passenger wiper to the rest of the linkage is broken/come loose. Has anyone heard of this issue?

The passenger wiper is also loose, i.e. I can rotate it with little effort which kind of reinforces my belief that the passenger wiper linkage has come loose from the rest of the linkage.
madmax9876 is offline  
Sponsored Links
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,208
You need to inspector really, it could just be the bolt holding the wiper to the linkage over the spline is loose
giblets46 is offline  
(Post Link) post #3 of 3 Old 04-02-16 Thread Starter
Status: -
AO Member
Join Date: Feb 2016
County: -
Posts: 20
It's sorted now - I took the wipers off and the plastic surrounding the wiper assembly, tested it and the wiper motor and linkage were working fine. What had happened was the nut holding the passenger wiper in place became loose, so when I put it all back together again it now works fine
madmax9876 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , alfa , broken , passenger , side , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome