Blue smoke on Startup - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-01-16 Thread Starter
Status: -
AO Member
Join Date: Dec 2015
Location: Gunness, North Lincs
County: -
Posts: 41
Blue smoke on Startup

My 159 1.9 JTDM has had its DPF removed and the EGR valve blanked and has had these mapped out of the ECU. The car has also had a new turbo and inlet manifold in the last 6K. When starting from cold there is always a puff of blue smoke coming out of the exhaust. It clears immediately and as far as I can tell it is clear from then on. The car runs great other than this just wondering what it could be? I did wonder if after the remap it is over fueling at startup but I would have thought that would have been black not blue smoke. I have had issues with the outside temp gauge reading way too low but I think I have fixed that now and it seems to be reading roughly the right value.
Cmdrew is offline  
Sponsored Links
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,198
It's normal, a bit of oil and a bit of fuel

Sent from Free App[/color
giblets46 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

blue , smoke , startup

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome