battery issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 19-12-15 Thread Starter
Status: -
Join Date: Dec 2015
County: -
Posts: 4
battery issues

Evening all
Decided to attempt a radio swap today but waved white flag and left it be.
I unhooked the neg terminal prior to working on the car
Once I reconnected the neg terminal and tried to start the car I got nothing. No power, then an occasional flash of dash lights.
Took the neg terminal off and tried again and the car started.
Driven it today fine then stalled it tonight and lost power again, couldn't start the car up. Hood up disconnected neg terminal restart and off I got going again.
Everything was fine until today so clearly I've aggravated something.
Terminal was a git grubby so cleaned it up a bit.
Only got my 159 a month ago and love it besides this and the squeaky clutch which I've seen is a common problem, which I hope to get fixed soon
Any tips would be helpful
Cheers people!
Delbee is offline  
Sponsored Links
Status: 16Italiancylinders(V 6,N4,L2,V2,V2)+1Span ish
AO Silver Member
swq4's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 1,506
Images: 28
It is easy to reconnect that terminal insecurely.
Make sure the ring connector is fully down (i push it down with a large socket) and once lever engaged the connector does not twist.
Might be worth checking the other ends of earth = under the battery plate too.
swq4 is offline  
Status: Still very confused
AO Member
Join Date: Feb 2005
Location: United Kingdom
County: Cheshire
Posts: 844
It's well worth checking all he earth connections, battery to body, to engine etc, there are a few. It's a typical issues with all Alfa's.
Philjay50 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

battery , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome