159 main light not working, but no warning light on dash - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 02-12-15 Thread Starter
Status: -
Join Date: Nov 2015
County: -
Posts: 3
159 main light not working, but no warning light on dash

Hello, my 159's left main light isn't working. I recently did a hid conversion. But there are no warning lights on the dash. At points the whole left side would not work but then I'd turn it off and then on again before it'd work again. The last time i did that and it worked, the side like on the left hand side started working. Can anybody suggest reasons please?
Alfa_rush is offline  
Sponsored Links
Status: funked up
Global Mod Team
paintergirl's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Dumfries and Galloway
Posts: 9,444
Images: 2
Thread moved to 159 lounge
paintergirl is offline  
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,198
The main light (dipped beam) is not on the canbus system, so night warning light will be seen, they expect drivers to notice the difference with that one off!

[color=gray]Sent from AutoGuide.com Free App[/color]
giblets46 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , dash , light , main , warning , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome