I love this forum! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 23-11-15 Thread Starter
Status: Back in the Alfa Fold again
AO Member
SanRemo78's Avatar
Join Date: Nov 2009
Location: United Kingdom
County: Lancashire
Posts: 575
I love this forum!

MOT time is approaching and from day 1 (of my ownership) the Xenon washers haven't worked. A little research on this site pointed to there being a failed one way valve and an idiot guide on how to remove the front bumper.
Started at 10.30, 12.30 it's all back together again having replaced the offending part with a simple Y piece removed from the Stratos' air horns and I also took the opportunity to replace one of the lower plastic grills that had big chunks missing and also reglue one of the front parking sensors fully back into place. All the fixing bolts went back on liberally greased so that the next time they need to come off there won't be any fighting me (only one this time and it didn't give too much resistance).
Looks like the car had a very minor knock on the front offside corner at some point damaging the grille and tearing the plastic below the foglight. No metal damage behind it fortunately.
Just need to replace the one way valve when I can find one, until then it'll just have to drain back slowly.


SanRemo78 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

forum , love

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome