Constant issues with 159 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-11-15 Thread Starter
Status: -
AO Member
Join Date: Sep 2015
County: -
Posts: 20
Constant issues with 159

Long story short. 3 months ago my 159 diesel started hesitating/juttering in low gears at 20/30mph - with a kind of scraping sound.

First garage says 'dunno'
Second garage - DPF unblock/engine deep clean.

10 miles later... I broke down.. Car went into limp mode. Back to garage 2.

Garage says faulty EGR. Replaces it. I drive off. Car limps again. Back to garage, they say turbo veins are catching the casing and aren't spinning properly. I can't afford to carry on with this right now...

I take it to an Alfa specialist who says turbo not working properly, there's also oil in one of the hoses.

I take it to another mechanic. He says actuator on turbo was stuck shut, not working. Replaced actuator and now cars out of limp, drives like a beaut. Hesitation / juttering still there with scraping sound. 300 miles later car doesn't like starting.

Last 4 times I went out, 3 of them needed a good 5 attempts at firing her up. Climate control has also decided it doesn't want to play anymore either.

Anyone have any bright ideas? Or a grenade ? If it is the turbo I'll get it done, I'm just sick of throwing money playing a guessing game. There's some beer in it for anyone who knows a fix orrrrrr it's going off a cliff lol

cauty2010 is offline  
Sponsored Links
Status: supporting a bank near you
AO Silver Member
Top Down's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: West Sussex
Posts: 3,526
Images: 3
I would suggest that rather than take it to every garage in the area to get an opinion, you take it to a reputed (recommended) Alfa Romeo specialist and get them to sort it out. It will cost money, but then at the moment your car is almost unusable by the sounds of it.

if you would like to tell us where you are perhaps someone will recommend a specialist.
Top Down is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , constant , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome